NLTK及nltk_data安装教程

安装nltk pip3 install nltk 安装nltk_data 打开 https://github.com/nltk/nltk_data 页面,点击绿色按钮下载整个压缩包。可以通过解压缩到指定的目录(目录可运行下面代码) import nltk print(nltk.data.path) 测试 from nltk.book import * #输出以下结果则安装成功 *** Introductory Examples for the NLTK Book *** Loading ...

Win11设置定时任务自动执行python脚本

工作中需要设置定时任务自动执行python脚本,需要是每天执行一次。当然windows提供了多种选择,基本能满足所有的需求。本文只列出了关键的步骤,能够在关闭远程桌面,仍然可以执行任务。 下面选择【只有用户登录时运行】,我们只要关闭远程桌面就可以 【程序或脚本】选择python.exe的安装目录;【添加参数可选】选择需要运行的脚本路径,需要完整路径包括文件名;【起始于】选择脚本所在目录。

django 'gbk' codec can't decode byte

UnicodeDecodeError: 'gbk' codec can't decode byte 0xa6 in position 9737: illegal multibyte sequence,解决办法是打开django/views/下面的debug.py文件,在第331行的open()中,加上encoding="utf-8"即可。

mysql升级到5.7

直接开始正题 1.依次执行下面语句,删除现有的版本 sudo rm /var/lib/mysql/ -R sudo rm /etc/mysql/ -R sudo rm /usr/include/mysql/ -R sudo rm /usr/local/mysql/ -R sudo apt-get autoremove mysql* --purge sudo apt-get remove apparmor 2.删除完以后,进行服务器重启 reboot ...

The remote name could not be resolved: 'api.weixin.qq.com'

今天在使用微信接口时,发生了报错,报错信息如下: The remote name could not be resolved: 'api.weixin.qq.com' 感觉是网络连接问题,重启了IIS,重启了服务器,都没有用,还是一样的报错!baidu一通后,有说可以修改windows的etc/hosts。 ping 域名拿到IP地址 添加IP和域名的对应关系到hosts文件中 保存 黏贴覆盖文件 重新访问就可以了 ...

Ubuntu14.04升级到Ubuntu16.04

执行阿里云快照,做好备份,查看当前版本: lsb_release -a 下面开始更新版本 1.更新资源 $ sudo apt-get update $ sudo apt-get upgrade $ sudo apt dist-upgrade 2.安装update-manager-core $ sudo apt-get install update-manager-core ...

python密码包含特殊字符的连接字符串

使用sqlalchemy的create_engine创建连接数据库的字符串,如下: engine = create_engine('postgres://user:pass@host/database') 运行后出错,把密码和数据库地址识别错了,因为密码里包含了特殊字符@,被解释为定界符,导致密码和数据库地址被识别错误,无法连接数据库。 可以使用下面的方式解决: from urllib import parse connect = ...

PyPDF2设置pdf文件读写编辑和打印权限

因为业务需要,需要批量生成证书文件。想到pdf可以实现读写编辑和打印权限。 实现的代码如下: def add_encryption(input_pdf, output_pdf, password): pdf_writer = PdfFileWriter() pdf_reader = PdfFileReader(input_pdf) for page in range(pdf_reader.getNumPages()): ...

ssh tunnel:the negotiation of encryption is failed

在navicat使用ssh通道连接服务器端数据库时,会出现 ssh tunnel:the negotiation of encryption is failed 或者 ssh tunnel:server does not support diffie-hellman-group1-sha1 forkeyexchange 的问题 这是因为服务器关于ssh的加密设置没有和navicat协调好 此时,需要修改服务器配置文件,方法如下: 命令行打开 vi /etc/ssh/sshd_config ...

Ubuntu 14.04 手动编译安装apache httpd 服务器

因为系统比较老了,加之做了一些配置上的修改,无法通过安装命令(sudo apt-get install apache2)直接安装,所以只能通过手动编译安装,安装步骤如下: 下载apache httpd 源码:https://httpd.apache.org/download.cgi 这里选择最新的版本 httpd-2.4.51.tar.gz [ PGP ] [ SHA256 ] [ SHA512 ] 解压缩:tar -zxvf httpd-2.4.51.tar.gz 下载apr, ...